Ubuntu – Toutes suggestions sur l’installation de la plate-forme haskell ou de la pile dans ubuntu

J’ai essayé d’installer haskell-platform et j’obtiens les dépendances non satisfaites suivantes.

 
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies: haskell-platform : Depends: ghc (>= 7.6.3) but it is not going to be installed Depends: ghc (< 7.6.3+) but it is not going to be installed Depends: libghc-async-dev (>= 2.0.1.4) but it is not going to be installed Depends: libghc-async-dev (< 2.0.1.4+) but it is not going to be installed Depends: libghc-attoparsec-dev (>= 0.10.4.0) but it is not going to be installed Depends: libghc-attoparsec-dev (< 0.10.4.0+) but it is not going to be installed Depends: libghc-case-insensitive-dev (>= 1.0.0.1) but it is not going to be installed Depends: libghc-case-insensitive-dev (< 1.1.0.2+) but it is not going to be installed Depends: libghc-cgi-dev (>= 3001.1.8.3) but it is not going to be installed Depends: libghc-cgi-dev (< 3001.1.8.3+) but it is not going to be installed Depends: libghc-fgl-dev (>= 5.4.2.4) but it is not going to be installed Depends: libghc-fgl-dev (< 5.4.2.4+) but it is not going to be installed Depends: libghc-gluraw-dev (>= 1.3.0.0) but it is not going to be installed Depends: libghc-gluraw-dev (< 1.3.0.0+) but it is not going to be installed Depends: libghc-glut-dev (>= 2.4.0.0) but it is not going to be installed Depends: libghc-glut-dev (< 2.4.0.0+) but it is not going to be installed Depends: libghc-hashable-dev (>= 1.2.1.0) but it is not going to be installed Depends: libghc-hashable-dev (< 1.2.1.0+) but it is not going to be installed Depends: libghc-haskell-src-dev (>= 1.0.1.5) but it is not going to be installed Depends: libghc-haskell-src-dev (< 1.0.1.5+) but it is not going to be installed Depends: libghc-html-dev (>= 1.0.1.2) but it is not going to be installed Depends: libghc-html-dev (< 1.0.1.2+) but it is not going to be installed Depends: libghc-http-dev (>= 1:4000.2.8) but it is not going to be installed Depends: libghc-http-dev (< 1:4000.2.8+) but it is not going to be installed Depends: libghc-hunit-dev (>= 1.2.5.2) but it is not going to be installed Depends: libghc-hunit-dev (< 1.2.5.2+) but it is not going to be installed Depends: libghc-mtl-dev (>= 2.1.2) but it is not going to be installed Depends: libghc-mtl-dev (< 2.1.2+) but it is not going to be installed Depends: libghc-network-dev (>= 2.4.1.2) but it is not going to be installed Depends: libghc-network-dev (< 2.4.1.2+) but it is not going to be installed Depends: libghc-opengl-dev (>= 2.8.0.0) but it is not going to be installed Depends: libghc-opengl-dev (< 2.8.0.0+) but it is not going to be installed Depends: libghc-parallel-dev (>= 3.2.0.3) but it is not going to be installed Depends: libghc-parallel-dev (< 3.2.0.3+) but it is not going to be installed Depends: libghc-parsec3-dev (>= 3.1.3) but it is not going to be installed Depends: libghc-parsec3-dev (< 3.1.3+) but it is not going to be installed Depends: libghc-primitive-dev (>= 0.5.0.1) but it is not going to be installed Depends: libghc-primitive-dev (< 0.5.0.1+) but it is not going to be installed Depends: libghc-quickcheck2-dev (>= 2.6) but it is not going to be installed Depends: libghc-quickcheck2-dev (< 2.6+) but it is not going to be installed Depends: libghc-regex-base-dev (>= 0.93.2) but it is not going to be installed Depends: libghc-regex-base-dev (< 0.93.2+) but it is not going to be installed Depends: libghc-regex-compat-dev (>= 0.95.1) but it is not going to be installed Depends: libghc-regex-compat-dev (< 0.95.1+) but it is not going to be installed Depends: libghc-regex-posix-dev (>= 0.95.2) but it is not going to be installed Depends: libghc-regex-posix-dev (< 0.95.2+) but it is not going to be installed Depends: libghc-split-dev (>= 0.2.2) but it is not going to be installed Depends: libghc-split-dev (< 0.2.2+) but it is not going to be installed Depends: libghc-stm-dev (>= 2.4.2) but it is not going to be installed Depends: libghc-stm-dev (< 2.4.2+) but it is not going to be installed Depends: libghc-syb-dev (>= 0.4.0) but it is not going to be installed Depends: libghc-syb-dev (< 0.4.0+) but it is not going to be installed Depends: libghc-text-dev (>= 0.11.3.1) but it is not going to be installed Depends: libghc-text-dev (< 0.11.3.1+) but it is not going to be installed Depends: libghc-transformers-dev (>= 0.3.0.0) but it is not going to be installed Depends: libghc-transformers-dev (< 0.3.0.0+) but it is not going to be installed Depends: libghc-unordered-containers-dev (>= 0.2.3.0) but it is not going to be installed Depends: libghc-unordered-containers-dev (< 0.2.3.0+) but it is not going to be installed Depends: libghc-vector-dev (>= 0.10.0.1) but it is not going to be installed Depends: libghc-vector-dev (< 0.10.0.1+) but it is not going to be installed Depends: libghc-xhtml-dev (>= 3000.2.1) but it is not going to be installed Depends: libghc-xhtml-dev (< 3000.2.1+) but it is not going to be installed Depends: libghc-zlib-dev (>= 0.5.4.1) but it is not going to be installed Depends: libghc-zlib-dev (< 0.5.4.1+) but it is not going to be installed Depends: ghc-haddock but it is not going to be installed

 

Ces dépendances sont différentes des autres questions, ici et ici, sur ce site.

Certains packages mentionnés dans la première question sont également ceux que j’ai rencontrés, j’ai donc implémenté la solution là-bas. Cependant, je ne pouvais pas le faire fonctionner (les mêmes dépendances continuaient à apparaître).

Laissant de côté pendant un moment, j’ai essayé d’installer le
pile de haskell.
Cependant, il me faut installer le package libgmp3-dev . Je n’arrive pas à l’installer en utilisant synaptic ou sudo apt-get install .

Je recherche des suggestions d’installation haskell-platform ou à défaut ghc compilateur sur mon système. je cours Ubuntu 14.04