Ubuntu – Software-properties-gtk ne fonctionne pas

Ubuntu 16.04

software-properties-gtk ne fonctionne pas. J’ai vu quelques erreurs avec le dossier / usr / bin / python. J’espérais, je vais le réparer moi-même.

J’ai supprimé le dossier python3 dans / usr / bin / (oui, je sais que c’était stupide)

Quand je cours software-properties-gtk la SORTIE est:

 bash: /usr/bin/software-properties-gtk: /usr/bin/python3: bad interpreter: No such file or directory 

Comment corriger cette erreur?

UPDATE:

Quand je tape sudo apt-get install --reinstall python-minimal , OUTPUT est:

 Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 28,1 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://pl.archive.ubuntu.com/ubuntu xenial-updates/main amd64 python-minimal amd64 2.7.12-1~16.04 [28,1 kB]
Fetched 28,1 kB in 0s (77,8 kB/s)
(Reading database ... 248904 files and directories currently installed.)
Preparing to unpack .../python-minimal_2.7.12-1~16.04_amd64.deb ...
Unpacking python-minimal (2.7.12-1~16.04) over (2.7.12-1~16.04) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python3-minimal (3.5.1-3) ...
/var/lib/dpkg/info/python3-minimal.postinst: 5: /var/lib/dpkg/info/python3-minimal.postinst: py3compile: Permission denied
dpkg: error processing package python3-minimal (--configure):
subprocess installed post-installation script returned error exit status 126
Setting up python-minimal (2.7.12-1~16.04) ...
Errors were encountered while processing:
python3-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Meilleure réponse

  • Ici, je vais résumer toutes les mesures qui ont été prises pour résoudre le problème:

    1. Installez les packages comme d’habitude:

       sudo apt-get install --reinstall python3-minimal
      sudo apt-get install --reinstall python-minimal
       
    2. Installez les packages à bas niveau:

       sudo dpkg -i --force-all /var/cache/apt/archives/python-minimal_2.7.12-1~16.04_amd64.deb 
      sudo dpkg -i --force-all /var/cache/apt/archives/python3-minimal_3.5.1-3_amd64.deb
       
    3. Extrayez les packages directement dans le système de fichiers, puis continuez comme d’habitude:

       sudo dpkg -x /var/cache/apt/archives/python-minimal_2.7.12-1~16.04_amd64.deb /
      sudo dpkg -x /var/cache/apt/archives/python3-minimal_3.5.1-3_amd64.deb /
      sudo apt-get install -f
      sudo dpkg --configure -a