Ubuntu – Libdb4.8 ++ n’est plus disponible

J’essaie d’utiliser QT-Creator pour créer un programme et je reçois le message libdb4.8++ est nécessaire et n’est pas disponible.

J’ai essayé d’utiliser libdb5.1 et libdb4.8 mais il demande toujours libdb4.8++ 

J’utilise actuellement Ubuntu 12.04 LTS. Avec quelle version d’Ubuntu serait compatible libdb4.8++ s’il n’y a aucun moyen de l’installer?

Meilleure réponse

  • Ubuntu lucid (10.04) avait libdb4.8++ , et en ajoutant une entrée pour celle-ci à votre /etc/apt/sources.list vous pouvez l’installer:

     (echo deb http://de.archive.ubuntu.com/ubuntu/ lucid main restricted universe multiverse; echo deb http://de.archive.ubuntu.com/ubuntu/ lucid-updates main restricted universe multiverse; echo deb http://security.ubuntu.com/ubuntu lucid-security main restricted universe multiverse) | sudo sh -c 'cat >>/etc/apt/sources.list'
    sudo apt-get update
    sudo apt-get install libdb4.8++