Ubuntu – Impossible d’installer xserver-xorg-video-dumthe sur Ubuntu14.04

Je n’aime pas poster de questions mais j’ai passé des heures à chercher et j’ai vraiment besoin d’aide! J’essaie d’exécuter Ubuntu 14.04 sans tête et de me connecter à distance via VNC à partir de Windows. J’ai lu de nombreux articles sur la façon de procéder: installer xserver-xorg-video-dummy et c’est là que je suis coincé

[email protected]:~# apt-get install xserver-xorg-video-dummy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-dummy : Depends: xorg-video-abi-15
                            Depends: xserver-xorg-core (>= 2:1.14.99.902)
E: Unable to correct problems, you have held broken packages.

[email protected]:~#
[email protected]:~#
[email protected]:~#
[email protected]:~# apt-get install xorg-video-abi-15
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'xserver-xorg-core' instead of 'xorg-video-abi-15'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
[email protected]:~#

On dirait que le libcheese est le coupable. J’obtiens la même sortie si j’essaie d’installer xserver-xorg-core . From the above, looks like I need >= 3.4, however, mine is at 3.10

root @ mediaserver: ~ # dpkg -s libcheese-gtk23
Paquet: libcheese-gtk23
Statut: installer ok installé
...
Version: 3.10.2-0ubuntu2

Lorsque j’essaie de le mettre à niveau, j’obtiens ceci:

root @ mediaserver: ~ # apt-get upgrade libcheese-gtk23
Lecture des listes de packages ... Terminé
Construction d'un arbre de dépendance
Lecture des informations d'état ... Terminé
Calcul de la mise à niveau ... Terminé
libcheese-gtk23 est déjà la dernière version.
0 mis à niveau, 0 nouvellement installé, 0 à supprimer et 0 non mis à niveau.

Est-ce un problème avec mon référentiel ??? Je les ai tous commentés par l’ONU. Suis-je absent d’un référentiel spécial qui ne serait pas inclus dans 14.04?

Aidez-moi !!! Merci d’avance

root @ mediaserver: ~ # uname -a
Linux mediaserver 3.16.0-31-generic # 41 ~ 14.04.1-Ubuntu SMP Wed Feb 11 19:30:43 UTC 2015 i686 i686 i686 GNU / Linux

Meilleure réponse

  • Il s’agit d’un problème de dépendance dans le gestionnaire de packages comme ce problème

    J’ai essayé aptitude et les solutions proposées ont détruit toute l’installation d’ubuntu …

    Vous devez installer d’autres packages avant d’installer le pilote factice
    Essayez ceci et cela résoudra le problème:

     apt-get install  libglew-dev libcheese7 libcheese-gtk23 libclutter-gst-2.0-0 libcogl15 libclutter-gtk-1.0-0 libclutter-1.0-0  xserver-xorg-input-all